Risoluzione dei problemi quando Avast Antivirus continua a segnalare il software Java come non aggiornato

Software Updater in Avast Antivirus segnala che il software Java 6 o Java 7 non è aggiornato e che il computer è esposto a rischi. Tentando di eseguire l'aggiornamento in Avast, si viene reindirizzati a questa pagina:

Questo problema è causato dal software Java 6 o Java 7 obsoleto. Oracle ha interrotto il supporto per Java 6 a febbraio 2013 e per Java 7 a febbraio 2016. È pertanto consigliabile installare la versione più recente di Java.

Quando si installa una nuova versione di Java, il programma di installazione non rimuove automaticamente i file obsoleti del software Java 6 o Java 7. Ciò significa che Software Updater in Avast Antivirus continua a segnalare Java come obsoleto fino a quando i file obsoleti non vengono rimossi o aggiornati a una versione supportata di Java.

Risolvere i problemi di Software Updater causati da una versione obsoleta di Java

  1. Disinstallare il software Java 6 o Java 7 obsoleto.

    Per informazioni dettagliate, visitare la seguente pagina del sito Web di Oracle:
  2. Installare la versione più recente di Java.

    Per informazioni dettagliate, visitare la seguente pagina del sito Web di Oracle:
Java 6 (o 7) potrebbe essere necessario per il corretto funzionamento di alcuni programmi. Se Java 6 (o 7) viene rimosso, il comportamento di questi programmi può cambiare.

Se è necessario continuare a utilizzare la versione precedente di Java 6 o Java 7 e non si desidera visualizzare gli avvisi sugli aggiornamenti consigliati, è possibile configurare Software Updater in Avast Antivirus in modo da ignorare gli aggiornamenti di Java 6 (o 7) A PROPRIO RISCHIO:

  1. Aprire l'interfaccia utente di Avast e passare a PrestazioniSoftware Updater.
  2. Fare clic sulla freccia rivolta verso il basso nel riquadro Java Runtime Environment 6 (o 7) per espanderlo.
  3. Fare clic su Ignora aggiornamenti.

Software Updater interrompe la visualizzazione degli avvisi che segnalano che il computer è vulnerabile a causa di una versione obsoleta del software Java 6 o Java 7.

  • Avast Premium Security 20.x
  • Avast Free Antivirus 20.x
  • Avast Omni 1.x
  • Avast Premier 19.x
  • Avast Internet Security 19.x
  • Avast Pro Antivirus 19.x
  • Microsoft Windows 10 Home / Pro / Enterprise / Education - 32/64 bit
  • Microsoft Windows 8.1 / Pro / Enterprise - 32/64 bit
  • Microsoft Windows 8 / Pro / Enterprise - 32/64 bit
  • Microsoft Windows 7 Home Basic / Home Premium / Professional / Enterprise / Ultimate - Service Pack 1, 32/64 bit

Questo articolo è stato utile?

No

Hai bisogno di ulteriore assistenza?

Contattaci