Résolution des problèmes d'alerte de version obsolète du logiciel Java par Avast Antivirus

La Software Updater d'Avast Antivirus signale que Java 6 ou Java 7 est obsolète et que votre ordinateur est exposé à des risques. Si vous essayez de procéder à la mise à jour dans Avast, vous serez redirigé vers cette page :

Ce problème est causé par les logiciels Java 6 ou Java 7 obsolètes. Oracle a cessé de prendre en charge Java 6 en février 2013 et Java 7 en février 2016, il est donc vivement recommandé d'installer la dernière version de Java.

Lorsque vous installez une version plus récente de Java, l'installateur ne supprime pas automatiquement les fichiers des versions Java 6 ou 7 obsolètes. Cela signifie que la mise à jour du logiciel d'Avast Antivirus continuera de signaler Java comme obsolète tant que les fichiers concernés n'auront pas été supprimés ou mis à jour dans une version de Java prise en charge.

Résoudre les problèmes de mise à jour de logiciels en cas d'obsolescence de Java

  1. Désinstallez la version de Java 6 ou 7 obsolète.

    Pour plus de détails, consultez la page suivante sur le site Web d’Oracle :
  2. Installez la dernière version de Java.

    Pour plus de détails, consultez la page suivante sur le site Web d’Oracle :
Certains programmes peuvent dépendre de Java 6 (ou 7) pour fonctionner. Si cette version est supprimée, leur comportement peut être altéré.

Si vous devez continuer à utiliser l'ancienne version de Java 6 ou 7 et si vous ne souhaitez pas être alerté lorsqu'une mise à jour est recommandée, vous pouvez configurer la Mise à jour de logiciels d'Avast Antivirus afin qu'elle ignore les mises à jour de Java 6 (ou 7) À VOS RISQUES ET PÉRILS :

  1. Ouvrez l'interface utilisateur d'Avast et accédez à PerformancesSoftware Updater.
  2. Cliquez sur la flèche vers le bas du panneau Java Runtime Environment 6 (ou 7) pour le développer.
  3. Cliquez sur Ignorer les mises à jour.

La mise à jour de logiciels arrête de vous prévenir que votre ordinateur est exposé à des risques parce que votre logiciel Java 6 ou 7 est obsolète.

  • Avast Premium Security 20.x
  • Avast Antivirus Gratuit 20.x
  • Avast Omni 1.x
  • Avast Premium 19.x
  • Avast Internet Security 19.x
  • Avast Pro Antivirus 19.x
  • Microsoft Windows 10 Famille/Pro/Entreprise/Enseignement - 32/64 bits
  • Microsoft Windows 8.1/Pro/Entreprise - 32/64 bits
  • Microsoft Windows 8/Pro/Entreprise - 32/64 bits
  • Microsoft Windows 7 Édition Familiale Basique/Édition Familiale Premium/Professionnel/Entreprise/Édition Intégrale - Service Pack 1, 32/64 bits

Cet article vous a-t-il aidé ?

Besoin d’aide supplémentaire ?

Contactez-nous