Risoluzione dei problemi quando Avast Antivirus continua a segnalare il software Java come non aggiornato

Software Updater in Avast Antivirus segnala che il software Java 6 o Java 7 non è aggiornato e che il computer è esposto a rischi. Tentando di eseguire l'aggiornamento in Avast, si viene reindirizzati a questa pagina:

Questo problema è causato dal software Java 6 o Java 7 obsoleto. Poiché Oracle ha interrotto il supporto per Java 6 a febbraio 2013 e quello per Java 7 a febbraio 2016, è consigliabile installare la versione più recente di Java.

Quando si installa una nuova versione di Java, il programma di installazione non rimuove automaticamente la versione precedente di Java 6 o Java 7. Software Updater in Avast Antivirus continua a segnalare il prodotto come non aggiornato finché la versione non aggiornata non viene rimossa o aggiornata all'ultima versione supportata.

Istruzioni

È consigliabile attenersi alla seguente procedura.

  1. Disinstallare il software Java 6 o Java 7 obsoleto.

    Per informazioni dettagliate, visitare la seguente pagina nel sito Web di Oracle:
  2. Installare la versione più recente di Java.

    Per informazioni dettagliate, visitare la seguente pagina nel sito Web di Oracle:
Il funzionamento di alcuni programmi può dipendere dal software Java 6 (o 7). Se quest'ultimo viene rimosso, il comportamento di tali programmi potrebbe variare.

Questo metodo non è consigliato.

Se è necessario continuare a utilizzare la versione precedente di Java 6 o Java 7 e non si desidera visualizzare gli avvisi sugli aggiornamenti consigliati, è possibile impostare Software Updater in Avast Antivirus in modo da ignorare gli aggiornamenti di Java 6 A PROPRIO RISCHIO:

  1. Aprire l'interfaccia utente di Avast e passare a ProtezioneSoftware Updater.
  2. Fare clic sulla freccia verso il basso nel riquadro Java Runtime Environment 6 (o 7) per espanderlo.
  3. Fare clic su Ignora aggiornamenti.

Software Updater in Avast Antivirus interromperà la visualizzazione degli avvisi che segnalano che il computer è vulnerabile a causa di un software Java 6 o Java 7 non aggiornato.

  • Avast Ultimate 17.x
  • Avast Premier 17.x
  • Avast Internet Security 17.x
  • Avast Pro Antivirus 17.x
  • Avast Free Antivirus 17.x
  • Microsoft Windows 10 Home / Pro / Enterprise / Education - 32/64 bit
  • Microsoft Windows 8.1 / Pro / Enterprise - 32/64 bit
  • Microsoft Windows 8 / Pro / Enterprise - 32/64 bit
  • Microsoft Windows 7 Home Basic / Home Premium / Professional / Enterprise / Ultimate - Service Pack 1, 32/64 bit
  • Microsoft Windows Vista Home Basic / Home Premium / Business / Enterprise / Ultimate - Service Pack 2, 32/64 bit
  • Microsoft Windows XP Home / Professional / Media Center Edition - Service Pack 3, 32 bit

Hai bisogno di ulteriore assistenza?

Contattaci